Search

Nexus Browser Requirements

System Check


Check your browser compatibility before you log in.

Nexus Browser Requirements

If you are using any browsers not listed here, Nexus performance cannot be guaranteed. Some tools/functionality may work; others may not. Please update your browser.

  • You must have Adobe Flash Player 10.1 or greater to use the Record Audio feature.
  • Ensure your browser has JavaScript and Cookies enabled.

Desktop Supported Web Browsers

  • Internet Explorer 11
  • Internet Explorer 10
  • Internet Explorer 9
  • Firefox (newest)
  • Firefox 24
  • Chrome (newest)
  • Safari 7.0   
  • Safari 6.0
  • Safari 5.1

Tablet Supported Web Browsers for Desktop Web

  • Android Browser (newest)
  • iOS Safari (newest)
  • Microsoft Surface Internet Explorer 11 & 10

Mobile Supported Web Browsers

  • iOS (Newest)
  • iOS 7 (iPhone 3GS/4/4S/5/5C/5S, iPod Touch 4/5, iPad 2/3/4/mini)
  • iOS 6  (iPhone 3GS/4/4S/5, iPod Touch 4/5, iPad 2/3/4/mini)
  • Android (Newest)
  • Android 4.3 (Jelly Bean)
  • Android 4.2 (Jelly Bean)
  • Android 4.1 (Jelly Bean)
  • Android 4.0 (Ice Cream Sandwich)
  • Blackberry 10
  • Blackberry 7