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The new Dell computers come with a CD-Recordable/ReWriteable drive installed as part of the standard desktop (hardware)
configuration. What is a CD-Recordable/ReWriteable drive? It is a CD drive that can not only read CDs but record CDs. That is, the
user can now take a blank recordable CD and record their own content onto it. One of the many uses of a drive like this is for recording
data CDs. There are many reasons for recording data (off your computer) onto a CD. It is an excellent way to backup or archive files.
It is an easy and convenient way to transfer files to another computer or distribute data to others.

The media itself (the actual CD disc) has many advantages. It is small, lightweight, and portable. It is an optical medium not a magnetic
medium, so there is no susceptibility to erasure from electrical charges or magnetic fields. CDs are durable – they last decades longer
than traditional storage (magnetic) media. CDs have a large storage capacity – 650 MB for a 74 minute CD or 700 MB for an 80 minute
CD. This is the equivalent of approximately 500 floppy discs! CDs are also extremely affordable. 

There are two types of recordable CDs:

CD-R (CD-Recordable) 
CD-R discs can be read by all CD-ROM, CD-Recordable, and CD-ReWriteable drives.  This type of disc is excellent for
permanent data storage and should be used when there is no need to erase data off the CD. They are the cheaper type.

CD-RW (CD-ReWriteable)
CD-RW discs can only be used for recording in CD-ReWriteable drives and read in newer MultiRead CD-ROM drives.
This type of disc can be erased and re-recorded over many times. 

Since the CD drives on the Dell computers are CD-Recordable/ReWriteable, either type of CD can be used. Tip: When recording a
CD to be used on another computer, use a CD-R disc – just in case it has an older CD drive that cannot read CD-RW discs.

Roxio Easy CD Creator 5

The software installed on the Dell computers to record CDs
is Roxio Easy CD Creator 5. This program is accessed
through the Start menu (Start > Programs > Roxio Easy CD
Creator 5 > Project Selector). The Project Selector Interface
appears. See Figure 1.

Move the mouse over the “make a data CD” button and 2
options light up – directCD and dataCD project. Click on
the dataCD project option. An untitled data CD project
window appears. See Figure 2.
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The top half of the window is
the Explorer window, listing all
the files/folders/drives on the
computer. The bottom window
is the data layout window. This
is where the data to be recorded
is organized. Simply select by
clicking on the files or complete
folders (to be recorded) in the
Explorer window and then click
on the Add button on the CD
layout toolbar. Alternately, files
can be added by clicking and
dragging them to the layout win-
dow. Continue this process until
all the desired files have been
added. A data CD layout can
consist of files and folders, as
well as audio files (WAV or
MP3 files, not music CD
tracks).

As files and folders are added to the layout, the CD Info Bar at the bottom of the project window show the amount of data (in
MBs) contained in the layout and how much free space remains on the CD. Please keep in mind that this is estimated free space.
See Figure 2.

The CD layout acts like a pointer to where the data is located on the hard drive. The files/folders themselves are not actually
moved or copied to the layout. Because of this, files in the layout can be moved around, deleted, and renamed without affecting
the actual data on the hard drive. 

The files in the layout window can be organized as desired. A new folder can be created in the layout. To create a new folder,
click anywhere in the CD layout window. Select New Folder from the Edit menu at the top of the project window. A new folder

appears on the left side of the
layout window. See Figure 3.
Type in a new name. 

Files/ folders can now be added
to this new folder. The order of
the files can be rearranged. Se-
lect the file or folder in the lay-
out window and drag it to the
position desired within the lay-
out. Files/folders can be re-
moved from the layout as well.
Simply select the file/folder in
the layout and click the Remove
button on the CD layout toolbar.
The names of file/folders listed
in the layout can be renamed
(this does not change the origi-
nal name of the file/folder on
the hard drive). Select the item
in the layout window and select
Rename from the Edit menu.
Type in a new name.

CD Info Bar
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When all the desired files/folders have been added to the layout, recording the CD can take place. If it is inconvenient to record at
this time, the data CD project can be saved. This project can then be opened and recorded at a later time. To save a project, select
Save Project List from the File menu. A Save As dialog box appears. See Figure 4.

Enter a file name and select a location on the hard drive.
Click save. The file will have an extension of filename.cl5.
To open a CD layout, start the program as described previ-
ously. Under the File menu, select Open CD Layout.
Browse and Select the CD layout desired and click Open.

Before the CD is recorded, it is a good idea to validate the
layout. What this does is checks the layout contents to make
sure that the actual files on the hard drive that the layout
points to have not been moved, deleted, renamed or modi-
fied since being added to the layout. If a data item cannot be
validated, a message will appear. The item should be deleted
from the layout before recording.

The CD properties must be set before recording. The settings here determine how the CD is recorded. Under the File menu, select
CD Project Properties. The CD Project Properties dialog box appears. See Figure 5. Only the properties pertaining to recording
data CDs will be covered. 

In the Volume Label space, type in a name to iden-
tify the CD. If a specific name is not typed in, the
default numerical sequence will be used to identify
the CD. This numerical sequence represents the
year, month, day and time the CD was created.

Under the File System, select the Joliet option. This
option allows for file names that contain up to 64
characters in length, including spaces. This is the
default option and is used to record most CDs.
Joliet also records the associated DOS-standard
name (8+3 characters) for each file so that the CD
may be read on DOS systems or earlier versions of
Windows. 
 
Under the Physical format of CD there are two
options, Mode 1 or Mode 2. Unless all the available
space (give or take about 30 MBs or so) on the CD
has been used up (check the Info bar), ensure that
Mode 2 is selected. Mode 2 allows more data or
another “session” to be recorded to the CD at a later
time if desired. If Mode 1 is selected, no more data
may be recorded to the CD. No sense recording a
CD with 50 MB of data and not having the option
of adding more data to it later.   

To record the CD, make sure to put a blank CD into
the CD-Recordable/ReWriteable drive. Click the
Record button on the project window toolbar (the
red button). See Figure 3. A Record CD Setup dia-
log box appears. See Figure 6. Only the options
pertaining to recording data CDs will be covered. 
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This dialog box lists the options for recording the  CD.
Select CD-R Drive: Select the CD-
Recorder to use for recording CDs. If
more than one CD-Recorder is con-
nected to the computer, select the
CD-Recorder to use from the drop-
down list box.

Write Speed: Select the speed of the
drive for recording CDs.  Change this
setting if you want to make the CD at
a different speed. Often there will
only be one choice for write speed. If
the system is not fast enough to write
at higher speeds, reduce the write
speed. Errors may occur during re-
cording if the write speed is set too
high. 

Note: Blank CDs are labeled with a
write speed. It is advisable not to ex-
ceed this speed.

Number of Copies: Type or select the
number of copies of the CD project
desired. If more than one copy is se-
lected, the recorded CD will eject and
the user will be prompted to add an-
other blank CD. This option is not
available if the Recording option is
set to Test and Record.

Buffer Underrun Prevention: Make sure this option is selected. It prevents some errors during the recording phase. This option is
available only when your CD-Recorder supports buffer underrun preventions.

Information: Displays information on the selected Record Method.

Options/Hide Options: Click this button to show or hide Record Options and Record Methods.

Record Options

•  Record CD: This option begins the recording process immediately.
•  Test Only: This option to performs a real test in which the files to be recorded are passed to the CD-Recorder. No actual             
    information is recorded to the CD. This is a useful way to check for any errors before recording.
•  Test and Record CD: This option performs a real test in which the files to be recorded are passed to the CD-Recorder. No         
     actual information is recorded to the CD during the test. Recording begins only after a successful test.

Select the Test and Record CD option. This is the safest way to record a CD. If the test detects any problems or errors with files or
folders, defects on the CD itself, or if the write speed is too high, recording will not take place. A message window will appear
stating the test was unsuccessful and why. Steps should be taken to correct these errors before attempting to record again.

Record Method

•  Track-at-Once: Select this option. 

•   Finalize Session. Don't Finalize CD: Select this option to finalize the session. The CD itself is not finalized so additional         
     sessions (data) can be added later. 
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•  Finalize CD: Select this option to finalize both the session and CD. Once the CD is finalized, you cannot add additional tracks   
    or data to the CD.

•  Set as Default: Click this button when you want to set the Record CD Setup default settings. Make your selections in the            
    Record CD Setup dialog box before clicking this button.

Once all the recording options have been set, click the Start Recording
button. If you are recording onto a CD-RW disk you will get the
following window.

Click OK. The Record CD Progress Window appears detailing the
recording process. When completed, the phrase “Finished” appears on
the right hand side of the window. See Figure 7. Click the OK button.
Eject the CD.

If the CD was recorded as a
Mode 2 disk and the CD
was not finalized, more
data can be recorded on it
provided there is available
free space. This is known
as adding another session
and the CD disk would
then be a multisession disk.
To add another session to a
CD, start the Easy CD Cre-
ator software as described
earlier. If the software is
already open, select File >
New CD Project > Data
CD. See below. 
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Insert the CD (with previously recorded data on it) into the CD-Recordable/ReWriteable drive. From the CD menu, select Import
Session. The Import Session Window appears. See Figure 8. The last recorded session on the CD is listed in this window. Select it
and click Import. 

All the files that had been previously recorded to the CD are now listed in the layout window. See Figure 9. 

Continue adding files and folders to the lay-
out as described earlier. Click Record when
finished. The Record CD Setup Window ap-
pears. See Figure 6 previously. Under the
Record Method, choose either Finalize Ses-
sion. Don’t Finalize CD or Finalize CD de-
pending on whether there is enough space for
another session. If not, then choose Finalize
CD. Click Start Recording. Sessions can con-
tinue to be added until the disk is close to
being full. Please keep in mind that closing a
session and writing the CD directory take up
space (MBs) on the CD. Therefore it is not
possible to record exactly 650 MB of data.
Keep an eye on the CD Info bar.

CD-RW disks can be erased. To erase a CD,
make sure the CD creator software is running.
Insert the CD to be erased. From the CD
menu, select Erase disc. The Erase CD dialog  
box appears. See Figure 10.

Select the Full Erase option. This ensures every physical bit of data on the CD-
RW disc is erased. Click the Start button. When the CD has been completely
erased, close the Erase CD box. Eject the CD.

That pretty much covers the basics of recording data CDs. For those who have
received a new Dell computer recently, start using the CD-Record-
able/ReWriteable drive. You will soon find it to be a useful and indispensable
device. It’s never been more convenient to back up or store large amounts of data. 
 È 


